Mandriva Linux Security Advisory : varnish (MDVSA-2014:036)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

Updated varnish packages fix security vulnerabilities :

Varnish before 3.0.5 allows remote attackers to cause a denial of
service (child-process crash and temporary caching outage) via a GET
request with trailing whitespace characters and no URI
(CVE-2013-4484).

Also, the services have been converted from SysV init scripts to
systemd-native services, which should allow for more consistent
behavior.

See also :

http://advisories.mageia.org/MGASA-2014-0065.html

Solution :

Update the affected lib64varnish-devel, lib64varnish1 and / or varnish
packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 72551 ()

Bugtraq ID: 63451

CVE ID: CVE-2013-4484

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now