Firefox ESR 17.x < 17.0.9 Multiple Vulnerabilities

This script is Copyright (C) 2013-2017 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a web browser that is potentially
affected by multiple vulnerabilities.

Description :

The installed version of Firefox ESR 17.x is earlier than 17.0.9, and
is, therefore, potentially affected by the following vulnerabilities :

- Memory issues exist in the browser engine that could
allow for denial of service or arbitrary code execution.
(CVE-2013-1718, CVE-2013-1719)

- Multiple use-after-free problems exist that could result
in denial of service attacks or arbitrary code
execution. (CVE-2013-1735, CVE-2013-1736)

- A buffer overflow is possible because of an issue with
multi-column layouts. (CVE-2013-1732)

- A JavaScript compartment mismatch could result in a
denial of service or arbitrary code execution.
Versions of Firefox 20 or greater are not susceptible to
the arbitrary code execution mentioned above.

- Incorrect scope handling for JavaScript objects with
compartments could result in denial of service or
possibly arbitrary code execution. (CVE-2013-1725)

- An object is not properly identified during use of
user-defined getter methods on DOM proxies. This could
result in access restrictions being bypassed.

See also :

Solution :

Upgrade to Firefox 17.0.9 ESR or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now