IDA Pro IDB Loader Code Execution

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by a
code execution vulnerability.

Description :

The version of IDA Pro, an interactive disassembler installed on the
remote host, is between versions 6.1 and 6.7. It is, therefore,
affected by a code execution vulnerability. A remote attacker can
exploit this, by convincing a user into loading a specially crafted
IDB (IDA database) file into IDA Pro, to execute arbitrary code.

The vulnerability is mitigated by an IDA plugin (btval.plw), which
was not detected.

See also :

https://www.hex-rays.com/vulnfix.shtml

Solution :

Download and install the btval plugins (and any other included files)
from the referenced vendor advisory.

Risk factor :

High / CVSS Base Score : 7.6
(CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.6
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 69180 ()

Bugtraq ID: 60116

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now