Shockwave Player <= 11.6.7.637 Multiple Vulnerabilities (APSB12-23)

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser plugin that is affected
by multiple vulnerabilities.

Description :

The remote Windows host contains a version of Adobe's Shockwave Player
that is equal to or earlier than 11.6.7.637 and is, therefore,
potentially affected by the following vulnerabilities :

- Several unspecified errors exist that can lead to
buffer overflow vulnerabilities and possible code
execution. (CVE-2012-4172, CVE-2012-4173, CVE-2012-4174,
CVE-2012-4175, CVE-2012-5273)

- An array out-of-bounds error exists that can lead to
code execution. (CVE-2012-4176)

A remote attacker could exploit these issues by tricking a user into
viewing a malicious Shockwave file, resulting in arbitrary code
execution.

See also :

http://www.adobe.com/support/security/bulletins/apsb12-23.html

Solution :

Upgrade to Adobe Shockwave Player 11.6.8.638 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now