Flash Player <= / 11.4.402.278 Multiple Vulnerabilities (APSB12-22)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.

Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Windows host is 11.x equal to or earlier than 11.4.402.278, or
10.x equal to or earlier than It is, therefore,
potentially affected by multiple vulnerabilities :

- Several unspecified issues exist that can lead to buffer
overflows and arbitrary code execution. (CVE-2012-5248,
CVE-2012-5249, CVE-2012-5250, CVE-2012-5251,
CVE-2012-5253, CVE-2012-5254, CVE-2012-5255,
CVE-2012-5257, CVE-2012-5259, CVE-2012-5260,
CVE-2012-5262, CVE-2012-5264, CVE-2012-5265,
CVE-2012-5266, CVE-2012-5285, CVE-2012-5286,

- Several unspecified issues exist that can lead to memory
corruption and arbitrary code execution. (CVE-2012-5252,
CVE-2012-5256, CVE-2012-5258, CVE-2012-5261,
CVE-2012-5263, CVE-2012-5267, CVE-2012-5268,
CVE-2012-5269, CVE-2012-5270, CVE-2012-5271,

- An unspecified issue exists having unspecified impact.

See also :


Solution :

Upgrade to Adobe Flash Player version, 11.4.402.287 or
later, or Google Chrome PepperFlash or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.3
Public Exploit Available : true