Apache 2.2.x < 2.2.23 Multiple Vulnerabilities

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is prior to 2.2.23. It is, therefore, potentially affected
by the following vulnerabilities :

- The utility 'apachectl' can receive a zero-length
directory name in the LD_LIBRARY_PATH via the 'envvars'
file. A local attacker with access to that utility
could exploit this to load a malicious Dynamic Shared
Object (DSO), leading to arbitrary code execution.

- An input validation error exists related to
'mod_negotiation', 'Multiviews' and untrusted uploads
that can allow cross-site scripting attacks.

Note that Nessus has not tested for these flaws but has instead relied
on the version in the server's banner.

See also :


Solution :

Upgrade to Apache version 2.2.23 or later.

Risk factor :

Medium / CVSS Base Score : 6.9
CVSS Temporal Score : 6.0
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 62101 ()

Bugtraq ID: 53046

CVE ID: CVE-2012-0883

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now