VMware Products Local Privilege Escalation (VMSA-2012-0007)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization application affected by a local
privilege escalation vulnerability.

Description :

The VMware Workstation installation detected on the remote host is
8.x earlier than 8.0.2 and thus is potentially affected by a local
privilege escalation vulnerability because the access control list of
the VMware Tools folder is incorrectly set.

By exploiting this issue, a local attacker could elevate his privileges
on Windows-based Guest Operating Systems.

See also :

http://www.vmware.com/security/advisories/VMSA-2012-0007.html
http://lists.vmware.com/pipermail/security-announce/2012/000172.html

Solution :

Upgrade to VMware Workstation 8.0.2 or later.

In addition to patching, VMware Tools must be updated on all non-
Windows guest VMs in order to completely mitigate the
vulnerability.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.6
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 58794 ()

Bugtraq ID: 53006

CVE ID: CVE-2012-1518

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now