VLC Media Player < 2.0.1 Multiple Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a media player that is affected by
multiple vulnerabilities.

Description :

The version of VLC media player installed on the remote host is
earlier than 2.0.1. Such versions are affected by multiple
vulnerabilities:

- The function 'MMSOpen' in the MMS access plugin
contains a boundary error that can allow a stack-based
buffer overflow when maliciously crafted MMS streams
are opened. (CVE-2012-1775)

- The Realrtsp plugin contains an unspecified error that
can allow a heap-based buffer overflow when maliciously
crafted Real rtsp streams are opened. (CVE-2012-1776)

See also :

http://www.nessus.org/u?f84212cb
http://www.videolan.org/security/sa1201.html
http://www.videolan.org/security/sa1202.html
http://www.videolan.org/vlc/releases/2.0.1.html
http://www.nessus.org/u?d62cd2cc
http://www.nessus.org/u?6d1dc580
http://www.nessus.org/u?22cac0f0
http://www.nessus.org/u?dbc08f65

Solution :

Upgrade to VLC Media Player version 2.0.1 or later. Alternatively,
remove any affected plugin files from VLC's plugins directory.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 58416 ()

Bugtraq ID: 52550
53391

CVE ID: CVE-2012-1775
CVE-2012-1776

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now