XnView < 1.98.6 Multiple Buffer Overflow Vulnerabilities

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application with multiple buffer
overflow vulnerabilities.

Description :

The version of XnView installed on the remote Windows host is earlier
than 1.98.6. As such, it is reportedly affected by multiple buffer
overflow vulnerabilities. These vulnerabilities are related to
processing FPX and PCX files, and can also be triggered by certain
directory names when browsing folders within the program. An attacker
could exploit these vulnerabilities by tricking a victim into opening
a specially crafted file that could allow for arbitrary code to be
executed in the context of the application.

See also :

http://newsgroup.xnview.com/viewtopic.php?f=35&t=25073

Solution :

Upgrade to XnView version 1.98.6 or later as that reportedly resolves
the issue.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 58386 ()

Bugtraq ID: 52405

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now