Mozilla Thunderbird 3.1 < 3.1.11 Multiple Vulnerabilities

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a mail client that is affected by
multiple vulnerabilities.

Description :

The installed version of Thunderbird 3.1 is earlier than 3.1.11.
Such versions are potentially affected by the following security
issues :

- Multiple memory safety issues can lead to application
crashes and possibly remote code execution.
(CVE-2011-2374, CVE-2011-2376, CVE-2011-2364,

- A use-after-free issue when viewing XUL documents with
scripts disabled could lead to code execution.

- A memory corruption issue due to multipart /
x-mixed-replace images could lead to memory corruption.

- When a JavaScript Array object has its length set to an
extremely large value, the iteration of array elements
that occurs when its reduceRight method is called could
result in code execution due to an invalid index value
being used. (CVE-2011-2371)

- Multiple dangling pointer vulnerabilities could lead to
code execution. (CVE-2011-0083, CVE-2011-2363,

- An error in the way cookies are handled could lead to
information disclosure. (CVE-2011-2362)

See also :

Solution :

Upgrade to Thunderbird 3.1.11 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.3
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now