Mandriva Linux Security Advisory : dhcp (MDVSA-2011:073)

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability has been found and corrected in ISC DHCP :

dhclient in ISC DHCP 3.0.x through 4.2.x before 4.2.1-P1, 3.1-ESV
before 3.1-ESV-R1, and 4.1-ESV before 4.1-ESV-R2 allows remote
attackers to execute arbitrary commands via shell metacharacters in a
hostname obtained from a DHCP message (CVE-2011-0997).

Additionally for Corporate Server 4 and Enterprise Server 5 ISC DHCP
has been upgraded from the 3.0.7 version to the 4.1.2-P1 version which
brings many enhancements such as better ipv6 support.

Packages for 2009.0 are provided as of the Extended Maintenance
Program. Please visit this link to learn more:
http://store.mandriva.com/product_info.php?cPath=149 products_id=490

The updated packages have upgraded to the 4.1.2-P1 version and patched
to correct this issue.

See also :

http://ftp.isc.org/isc/dhcp/dhcp-4.1.2-P1-RELNOTES
https://www.isc.org/software/dhcp/advisories/CVE-2011-0997

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 53369 ()

Bugtraq ID: 47176

CVE ID: CVE-2011-0997

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now