Mozilla Thunderbird 3.1 < 3.1.8 Multiple Vulnerabilities

This script is Copyright (C) 2011-2017 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a mail client that is affected by
multiple vulnerabilities.

Description :

The installed version of Thunderbird 3.1 is earlier than 3.1.8.
Such versions are potentially affected by multiple vulnerabilities :

- Multiple memory corruption errors exist and may lead to
arbitrary code execution. (MFSA 2011-01)

- An input validation error exists in the class,
'ParanoidFragmentSink', which allows inline JavaScript
and 'javascript:' URLs in a chrome document. Note that
no unsafe usage occurs in Mozilla products, however
community generated extensions could.(MFSA 2011-08)

- A buffer overflow exists related to JPEG decoding and
may lead to arbitrary code execution. (MFSA 2011-09)

See also :

Solution :

Upgrade to Thunderbird 3.1.8 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 52532 ()

Bugtraq ID: 46368

CVE ID: CVE-2010-1585

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now