Mandriva Linux Security Advisory : samba (MDVSA-2011:038)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability has been found and corrected in samba :

All current released versions of Samba are vulnerable to a denial of
service caused by memory corruption. Range checks on file descriptors
being used in the FD_SET macro were not present allowing stack
corruption. This can cause the Samba code to crash or to loop
attempting to select on a bad file descriptor set (CVE-2011-0719).

Packages for 2009.0 are provided as of the Extended Maintenance
Program. Please visit this link to learn more:
http://store.mandriva.com/product_info.php?cPath=149 products_id=490

The updated packages have been patched to correct this issue.

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 52469 ()

Bugtraq ID:

CVE ID: CVE-2011-0719

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now