Foxit Reader < 4.3.1.0218 Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.


Synopsis :

A PDF viewer installed on the remote host is affected by multiple
vulnerabilities.

Description :

The version of Foxit Reader installed on the remote Windows host is
prior to 4.3.1.0218. It is, therefore, affected by multiple
vulnerabilities :

- An integer overflow condition exists when parsing
certain ICC chunks. An attacker can exploit this, via
crafted ICC chunks in a PDF file, to cause a heap-based
buffer overflow, resulting in the execution of arbitrary
code. (CVE-2011-0332)

- A flaw exists in the JavaScript API related to the
createDataObject() function. An attacker can exploit
this, via a crafted PDF file using a call to that
function, to create or overwrite arbitrary files.
(VulnDB 71104)

See also :

http://www.nessus.org/u?c42223ae
https://www.foxitsoftware.com/support/security-bulletins.php
https://www.foxitsoftware.com/company/press.php?id=210

Solution :

Upgrade to Foxit Reader version 4.3.1.0218 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 52458 ()

Bugtraq ID: 46565
46763

CVE ID: CVE-2011-0332

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now