SeaMonkey < 2.0.10 Buffer Overflow

This script is Copyright (C) 2010-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser affected by a buffer
overflow vulnerability.

Description :

The installed version of SeaMonkey is earlier than 2.0.10. Such
versions are potentially affected by a heap-based buffer overflow
vulnerability.

The combination of DOM insertions and the handling of the JavaScript
function 'document.write()' exposes an error that can lead to a
heap-based buffer overflow.

Note that there have been reports that this issue is being actively
exploited in the wild.

See also :

https://bugzilla.mozilla.org/show_bug.cgi?id=607222
https://www.mozilla.org/en-US/security/advisories/mfsa2010-73/
http://www.nessus.org/u?dc608134

Solution :

Upgrade to SeaMonkey 2.0.10 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 50386 ()

Bugtraq ID: 44425

CVE ID: CVE-2010-3765

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now