Fedora 13 : xinha-0.96.1-2.fc13 (2010-9320)

This script is Copyright (C) 2010-2015 Tenable Network Security, Inc.


Synopsis :

The remote Fedora host is missing a security update.

Description :

Name: CVE-2010-1916 URL:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1916 Assigned:
20100511 Reference: MISC:
http://www.php-security.org/2010/05/10/mops-2010-019-serendipity-wysiw
yg-editor-plugin-configuration-injection-vulnerability/index.html
Reference: MISC:
http://www.php-security.org/2010/05/10/mops-2010-020-xinha-wysiwyg-plu
gin-configuration-injection-vulnerability/index.html The dynamic
configuration feature in Xinha WYSIWYG editor 0.96 Beta 2 and earlier,
as used in Serendipity 1.5.2 and earlier, allows remote attackers to
bypass intended access restrictions and modify the configuration of
arbitrary plugins via (1) crafted backend_config_secret_key_location
and backend_config_hash parameters that are used in a SHA1 hash of a
shared secret that can be known or externally influenced, which are
not properly handled by the 'Deprecated config passing' feature; or
(2) crafted backend_data and backend_data[key_location] variables,
which are not properly handled by the xinha_read_passed_data function.
NOTE: this can be leveraged to upload and possibly execute arbitrary
files via config.inc.php in the ImageManager plugin.

Note that Tenable Network Security has extracted the preceding
description block directly from the Fedora security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

http://www.nessus.org/u?65402989
http://www.nessus.org/u?f7cac87c
https://bugzilla.redhat.com/show_bug.cgi?id=591701
http://www.nessus.org/u?9a74e65b

Solution :

Update the affected xinha package.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Fedora Local Security Checks

Nessus Plugin ID: 47530 (fedora_2010-9320.nasl)

Bugtraq ID: 40033

CVE ID: CVE-2009-1916
CVE-2010-1916

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now