ClamAV < 0.96.1 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.

Synopsis :

The remote antivirus service is affected by multiple denial of service

Description :

According to its version, the clamd antivirus daemon on the remote
host is earlier than 0.96.1. Such versions are reportedly affected by
multiple vulnerabilities :

- An error exists within the 'cli_pdf()' function in
'libclamav/pdf.c' when processing certain PDF files.
(Bug 2016)

- An error exists within the 'parseicon()' function in
'libclamav/pe_icons.c' when processing PE icons. This
can be exploited to trigger an out-of-bounds access when
reading data and potentially cause a crash via a
specially crafted PE file. (Bug 2031)

See also :

Solution :

Upgrade to ClamAV 0.96.1 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 46706 (clamav_0_96_1.nasl)

Bugtraq ID: 40317

CVE ID: CVE-2010-1639

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now