CUPS < 1.4.3 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.

Synopsis :

The remote printer service is affected by multiple vulnerabilities.

Description :

According to its banner, the version of CUPS installed on the remote
host is earlier than 1.4.3. Such versions are affected by several
vulnerabilities :

- A pointer use-after-free vulnerability exists in the
abstract file descriptor handling code in the
'cupsdDoSelect' function in scheduler/select.c. A remote
attacker may be able to leverage this to hang or crash
the cupsd daemon by disconnecting while receiving a
listing with a large number of print jobs. (STR #3200)

- The lppasswd utility, when its setuid bit is enabled,
allowing a local user to elevaate privileges because it
uses an environment variable to override CUPS' default
directories and determine the location of a file with
localized message strings. (STR #3482)

See also :

Solution :

Upgrade to CUPS version 1.4.3 or later.

Risk factor :

High / CVSS Base Score : 7.2
CVSS Temporal Score : 6.0
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 45554 (cups_1_4_3.nasl)

Bugtraq ID: 37048

CVE ID: CVE-2009-3553

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now