Opera < 10.51 Multiple Vulnerabilities

This script is Copyright (C) 2010-2011 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
issues.

Description :

The version of Opera installed on the remote host is earlier than
10.51. Such versions are potentially affected by multiple issues :

- Large values in the HTTP Content-Length header can be
used to execute arbitrary code. (948)

- XSLT can be used to retrieve random contents of
unrelated documents. (949)

See also :

http://www.opera.com/support/kb/view/948/
http://www.opera.com/support/kb/view/949/
http://www.opera.com/docs/changelogs/windows/1051/
http://www.nessus.org/u?e494cf3e

Solution :

Upgrade to Opera 10.51 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 45121 ()

Bugtraq ID: 38519
38892

CVE ID: CVE-2010-1310
CVE-2010-1349

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now