Firefox 3.5 < 3.5.8 Multiple Vulnerabilities

This script is Copyright (C) 2010-2017 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of Firefox is 3.5.x earlier than 3.5.8. Such
versions are potentially affected by the following security issues :

- Multiple crashes can result in arbitrary code execution.
(MFSA 2010-01)

- The implementation of 'Web Workers' contained an error
in its handling of array data types when processing
posted messages. (MFSA 2010-02)

- The HTML parser incorrectly frees used memory when
insufficient space is available to process remaining
input. (MFSA 2010-03)

- A cross-site scripting issue exists due to
'window.dialogArguments' being readable cross-domain.
(MFSA 2010-04)

- A cross-site scripting issue exists when using SVG
documents and binary Content-Type. (MFSA 2010-05)

- Multiple crashes can result in arbitrary code execution.
(MFSA 2010-11)

- A cross-site scripting issue when using
'addEventListener' and 'setTimeout' on a wrapped object.
(MFSA 2010-12)

- It is possible to corrupt a user's XUL cache.
(MFSA 2010-14)

- The XMLHttpRequestSpy module in the Firebug add-on
exposes an underlying chrome privilege escalation
vulnerability. (MFSA 2010-21)

See also :

Solution :

Upgrade to Firefox 3.5.8 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now