Shockwave Player < 11.5.6.606 Multiple Vulnerabilities (APSB10-03)

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser plugin that is affected
by multiple vulnerabilities.

Description :

The remote Windows host contains a version of Adobe's Shockwave Player
that is earlier than 11.5.6.606. As such, it is potentially affected
by multiple issues :

- A buffer overflow vulnerability that could potentially
lead to code execution. (CVE-2009-4002)

- Multiple integer overflow vulnerabilities that could
lead to code execution. (CVE-2009-4003)

See also :

http://secunia.com/secunia_research/2009-61/
http://secunia.com/secunia_research/2009-62/
http://secunia.com/secunia_research/2009-63/
http://secunia.com/secunia_research/2010-1/
http://www.adobe.com/support/security/bulletins/apsb10-03.html

Solution :

Upgrade to Adobe Shockwave version 11.5.6.606 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 44094 ()

Bugtraq ID: 37870
37872

CVE ID: CVE-2009-4002
CVE-2009-4003

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now