Adobe AIR < 1.5.3 Multiple Vulnerabilities (APSB09-19)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

The remote Windows host contains a version of Adobe AIR that is
earlier than 1.5.3. Such versions are potentially affected by
multiple vulnerabilities :

- A vulnerability in the parsing of JPEG data could lead
to code execution. (CVE-2009-3794)

- A data injection vulnerability could lead to code
execution. (CVE-2009-3796)

- A memory corruption vulnerability could lead to code
execution. (CVE-2009-3797)

- A memory corruption vulnerability could lead to code
execution. (CVE-2009-3798)

- An integer overflow vulnerability could lead to code
execution. (CVE-2009-3799)

- Multiple crash vulnerabilities could lead to code
execution. (CVE-2009-3800)

See also :

http://www.adobe.com/support/security/bulletins/apsb09-19.html

Solution :

Upgrade to Adobe AIR 1.5.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 43069 (adobe_air_apsb09-19.nasl)

Bugtraq ID: 37266
37267
37269
37270
37273
37275

CVE ID: CVE-2009-3794
CVE-2009-3796
CVE-2009-3797
CVE-2009-3798
CVE-2009-3799
CVE-2009-3800

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now