Firefox < 3.0.14 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of Firefox is earlier than 3.0.14. Such
versions are potentially affected by the following security issues :

- Multiple memory corruption vulnerabilities could
potentially allow arbitrary code execution.
(MFSA 2009-47)

- An insufficient warning message is displayed when adding
or removing a PKCS11 module. In some cases, this can be
done remotely. A remote attacker could exploit this by
tricking a user into installing a malicious PKCS11 module,
which could facilitate man-in-them-middle attacks.
(MFSA 2009-48)

- The columns of a XUL tree element can manipulated in
a way that leads to a dangling pointer. A remote attacker
could exploit this to execute arbitrary code. (MFSA 2009-49)

- A URL containing certain Unicode characters with tall
line-height is displayed incorrectly in the location bar.
A remote attacker could use this to prevent a user from
seeing the full URL of a malicious site. (MFSA 2009-50)

- A remote attacker can leverage 'BrowserFeedWriter' to
execute JavaScript code with Chrome privileges.
(MFSA 2009-51)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2009-47/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-48/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-49/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-50/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-51/

Solution :

Upgrade to Firefox 3.0.14 or later

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now