SeaMonkey < 1.1.18 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

A web browser on the remote host is affected by multiple
vulnerabilities.

Description :

The installed version of SeaMonkey is earlier than 1.1.18. Such
versions are potentially affected by the following security issues :

- The browser can be fooled into trusting a malicious SSL
server certificate with a null character in the host name.
(MFSA 2009-42)

- A heap overflow in the code that handles regular
expressions in certificate names can lead to
arbitrary code execution. (MFSA 2009-43)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2009-42/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-43/

Solution :

Upgrade to SeaMonkey 1.1.18 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 40874 ()

Bugtraq ID: 35888
35891

CVE ID: CVE-2009-2404
CVE-2009-2408

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now