Firefox 3.5.x < 3.5.1 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is
affected by multiple flaws.

Description :

Firefox 3.5 is installed on the remote host. This version is
potentially affected by multiple flaws :

- It may be possible to crash the browser or potentially
execute arbitrary code by using a flash object that
presents a slow script dialog. (MFSA 2009-35)

- In certain cases after a return from a native function,
such as escape(), the Just-in-Time (JIT) compiler could
get into a corrupt state. An attacker who is able to
trick a user of the affected software into visiting a
malicious link may be able to leverage this issue to
run arbitrary code subject to the user's privileges.
(MFSA 2009-41)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2009-35/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-41/

Solution :

Upgrade to Firefox 3.5.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 39853 ()

Bugtraq ID: 35660
35767

CVE ID: CVE-2009-2467
CVE-2009-2477

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now