Mozilla Thunderbird < 2.0.0.21 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a mail client that is affected by
multiple vulnerabilities.

Description :

The installed version of Thunderbird is earlier than 2.0.0.21. Such
versions are potentially affected by the following security issues :

- There are several stability bugs in the browser engine
that could lead to crashes with evidence of memory
corruption. (MFSA 2009-01)

- By exploiting stability bugs in the browser engine, it
might be possible for an attacker to execute arbitrary
code on the remote system under certain conditions.
(MFSA 2009-07)

- It might be possible for a website to read arbitrary XML
data from another domain by using nsIRDFService and a
cross-domain redirect. (MFSA 2009-09)

- Vulnerabilities in the PNG libraries used by Mozilla
could be exploited to execute arbitrary code on the
remote system. (MFSA 2009-10)

- A URI-spoofing vulnerability exists because the
application fails to adequately handle specific
characters in IDN subdomains. (MFSA 2009-15)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2009-01/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-07/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-09/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-10/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-15/
http://www.nessus.org/u?6dcf34a9

Solution :

Upgrade to Mozilla Thunderbird 2.0.0.21 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now