Foxit Reader 2.x < 2.3 Build 3902 / 3.x < 3.0 Build 1506 Multiple Vulnerabilities

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

A PDF viewer installed on the remote host is affected by multiple
vulnerabilities.

Description :

The version of Foxit Reader installed on the remote Windows host is
2.x prior to 2.3 Build 3902 or 3.x prior to 3.0 Build 1506. It is,
therefore, affected by multiple vulnerabilities :

- An uninitialized memory dereference flaw exists due to
improper handling of a JBIG2 symbol dictionary segment
with zero new symbols. An unauthenticated, remote
attacker can exploit this, via a crafted PDF file, to
execute arbitrary code. (CVE-2009-0191)

- A flaw exists due to a failure to require user
authorization before preforming dangerous actions
defined in a PDF file. An unauthenticated, remote
attacker can exploit this, via a crafted PDF file, to
execute arbitrary commands. (CVE-2009-0836)

- A stack-based buffer overflow condition exists due to
improper sanitization of user-supplied input. An
unauthenticated, remote attacker can exploit this to
execute arbitrary code via a crafted PDF file having a
long relative or absolute path in a filename argument in
an action. Note that this issue only affects version
3.x. (CVE-2009-0837)

See also :

http://secunia.com/secunia_research/2009-11/
https://www.foxitsoftware.com/support/security-bulletins.php
https://www.foxitsoftware.com/company/press.php?id=97

Solution :

Upgrade to Foxit Reader version 2.3 Build 3902 / 3.0 Build 1506 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 35807 (foxit_reader_multiple_flaws.nasl)

Bugtraq ID: 34035

CVE ID: CVE-2009-0191
CVE-2009-0836
CVE-2009-0837

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now