Sun OpenOffice.org < 2.3 TIFF Parser Buffer Overflow Vulnerabilities

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a program that is affected by multiple
buffer overflow vulnerabilities.

Description :

The remote host is running a version of Sun Microsystems
OpenOffice.org that is affected by multiple integer overflows in its
TIFF document parser that can be triggered when parsing tags in TIFF
directory entries. If a remote attacker can trick a user into opening
a specially crafted TIFF document, this issue can be leveraged to
execute arbitrary code on the remote host subject to the user's
privileges.

See also :

http://www.nessus.org/u?7cb497e7
http://www.securityfocus.com/archive/1/479759/30/0/threaded
http://www.openoffice.org/security/cves/CVE-2007-2834.html

Solution :

Upgrade to Sun Microsystems OpenOffice.org version 2.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 26064 ()

Bugtraq ID: 25690

CVE ID: CVE-2007-2834

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now