Flash Player Multiple Vulnerabilities (APSB07-12)

This script is Copyright (C) 2007-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a browser plugin that is affected by
multiple issues.

Description :

According to its version number, the instance of Flash Player on the
remote Windows host could allow for arbitrary code execution by means
of a malicious SWF file.

In addition, it may also fail to sufficiently validate the HTTP
Referer header, which may aid in cross-site request forgery attacks.
This issue does not, though, affect Flash Player 9.

See also :

http://www.adobe.com/support/security/bulletins/apsb07-12.html

Solution :

Upgrade to Flash Player version 9.0.47.0 / 8.0.35.0 / 7.0.70.0 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 25694 (flash_player_apsb07-12.nasl)

Bugtraq ID: 24856

CVE ID: CVE-2007-3456
CVE-2007-3457

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now