Mandrake Linux Security Advisory : xli (MDKSA-2005:076)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing a security update.

Description :

A number of vulnerabilities have been found in the xli image viewer.
Tavis Ormandy of the Gentoo Linux Security Audit Team discovered a
flaw in the handling of compressed images where shell meta-characters
are not properly escaped (CVE-2005-0638). It was also found that
insufficient validation of image properties could potentially result
in buffer management errors (CVE-2005-0639).

The updated packages have been patched to correct these problems.

Solution :

Update the affected xli package.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 18106 (mandrake_MDKSA-2005-076.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0638
CVE-2005-0639

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now