Mandrake Linux Security Advisory : wxGTK2 (MDKSA-2005:002)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

Several vulnerabilities have been discovered in the libtiff package;
wxGTK2 uses a libtiff code tree, so it may have the same
vulnerabilities :

iDefense reported the possibility of remote exploitation of an integer
overflow in libtiff that may allow for the execution of arbitrary
code.

The overflow occurs in the parsing of TIFF files set with the
STRIPOFFSETS flag.

iDefense also reported a heap-based buffer overflow vulnerability
within the LibTIFF package could allow attackers to execute arbitrary
code. (CVE-2004-1308)

The vulnerability specifically exists due to insufficient validation
of user-supplied data when calculating the size of a directory entry.

The updated packages are patched to protect against these
vulnerabilities.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 16115 (mandrake_MDKSA-2005-002.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1183
CVE-2004-1307
CVE-2004-1308

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now