Mandrake Linux Security Advisory : koffice (MDKSA-2004:165)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

Chris Evans discovered numerous vulnerabilities in the xpdf package,
which also effect software using embedded xpdf code, such as koffice
(CVE-2004-0888).

Multiple integer overflow issues affecting xpdf-2.0 and xpdf-3.0. Also
programs like koffice which have embedded versions of xpdf. These can
result in writing an arbitrary byte to an attacker controlled location
which probably could lead to arbitrary code execution.

iDefense also reported a buffer overflow vulnerability, which affects
versions of xpdf <= xpdf-3.0 and several programs, like koffice, which
use embedded xpdf code. An attacker could construct a malicious
payload file which could enable arbitrary code execution on the target
system (CVE-2004-1125).

The updated packages are patched to protect against these
vulnerabilities.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 16082 (mandrake_MDKSA-2004-165.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0888
CVE-2004-1125

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now