Mandrake Linux Security Advisory : WindowMaker (MDKSA-2002:085)

This script is Copyright (C) 2004-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

Al Viro discovered a vulnerability in the WindowMaker window manager.
A function used to load images, for example when configuring a new
background image or previewing themes, contains a buffer overflow. The
function calculates the amount of memory necessary to load the image
by doing some multiplication but does not check the results of this
multiplication, which may not fit into the destination variable,
resulting in a buffer overflow when the image is loaded.

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 13983 (mandrake_MDKSA-2002-085.nasl)

Bugtraq ID:

CVE ID: CVE-2002-1277

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now