This script is Copyright (C) 2004-2013 Tenable Network Security, Inc.
The remote Mandrake Linux host is missing one or more security
An input validation error exists in the OpenSSH server between
versions 2.3.1 and 3.3 that can result in an integer overflow and
privilege escalation. This error is found in the
PAMAuthenticationViaKbdInt code in versions 2.3.1 to 3.3, and the
ChallengeResponseAuthentication code in versions 2.9.9 to 3.3. OpenSSH
3.4 and later are not affected, and OpenSSH 3.2 and later prevent
privilege escalation if UsePrivilegeSeparation is enabled; in OpenSSH
3.3 and higher this is the default behaviour of OpenSSH.
To protect yourself, users should be using OpenSSH 3.3 with
UsePrivilegeSeparation enabled (see MDKSA:2002-040). However, it is
highly recommended that all Mandrake Linux users upgrade to version
3.4 which corrects these errors.
There are a few caveats with this upgrade, however, that users should
be aware of :
- On Linux kernel 2.2 (the default for Mandrake Linux
7.x), the use of Compression and UsePrivilegeSeparation
are mutually exclusive. You can use one feature or the
other, not both; we recommend disabling Compression and
using privsep until this can be resolved.
- Using privsep may cause some PAM modules which expect to
run with root privilege to fail. For instance, users
will not be able to change their password if they
attempt to log into an account with an expired password.
If you absolutely must use one of these features that conflict with
privsep, you can disable it in /etc/ssh/sshd_config by using :
However, if you do this, be sure you are running OpenSSH 3.4. Updates
to OpenSSH will be made available once these problems are resolved.
See also :
Update the affected packages.
Risk factor :
Critical / CVSS Base Score : 10.0