Scientific Linux Security Update : libsoup on SL7.x x86_64

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

Security Fix(es) :

- A stack-based buffer overflow flaw was discovered within
the HTTP processing of libsoup. A remote attacker could
exploit this flaw to cause a crash or, potentially,
execute arbitrary code by sending a specially crafted
HTTP request to a server using the libsoup HTTP server
functionality or by tricking a user into connecting to a
malicious HTTP server with an application using the
libsoup HTTP client functionality. (CVE-2017-2885)

See also :

http://www.nessus.org/u?ebcf0907

Solution :

Update the affected libsoup, libsoup-debuginfo and / or libsoup-devel
packages.

Risk factor :

High

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 102670 ()

Bugtraq ID:

CVE ID: CVE-2017-2885

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now