Tenable SecurityCenter PHP < 5.6.27 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The Tenable SecurityCenter application on the remote host contains a
PHP library that is affected by multiple vulnerabilities.

Description :

The Tenable SecurityCenter application installed on the remote host
is missing a security patch. It is, therefore, affected by multiple
vulnerabilities in the bundled version of PHP :

- A use-after-free error exists in the unserialize()
function that allows an unauthenticated, remote attacker
to dereference already freed memory, resulting in the
execution of arbitrary code. (CVE-2016-9137)

- A NULL pointer dereference flaw exists in the
SimpleXMLElement::asXML() function within file
ext/simplexml/simplexml.c. An unauthenticated, remote
attacker can exploit this to cause a denial of service
condition. (VulnDB 145598)

- A heap-based buffer overflow condition exists in the
php_ereg_replace() function within file ext/ereg/ereg.c
due to improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit this to
cause a denial of service condition or the execution of
arbitrary code. (VulnDB 145599)

- A flaw exists in the openssl_random_pseudo_bytes()
function within file ext/openssl/openssl.c when handling
strings larger than 2GB. An unauthenticated, remote
attacker can exploit this to cause a denial of service
condition. (VulnDB 145600)

- A flaw exists in the openssl_encrypt() function within
file ext/openssl/openssl.c when handling strings larger
than 2GB. An unauthenticated, remote attacker can
exploit this to cause a denial of service condition.
(VulnDB 145601)

- An integer overflow condition exists in the
imap_8bit() function within file ext/imap/php_imap.c due
to improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit this to
cause a denial of service condition or the execution of
arbitrary code. (VulnDB 145602)

- A flaw exists in the _bc_new_num_ex() function within
file ext/bcmath/libbcmath/src/init.c when handling
values passed via the 'scale' parameter. An
unauthenticated, remote attacker can exploit this to
cause a denial of service condition. (VulnDB 145603)

- A flaw exists in the php_resolve_path() function within
file main/fopen_wrappers.c when handling negative size
values passed via the 'filename' parameter. An
unauthenticated, remote attacker can exploit this to
cause a denial of service condition. (VulnDB 145604)

- A flaw exists in the dom_document_save_html() function
within file ext/dom/document.c due to missing NULL
checks. An unauthenticated, remote attacker can exploit
this to cause a denial of service condition.
(VulnDB 145605)

- An integer overflow condition exists in the
mb_encode_*() functions in file ext/mbstring/mbstring.c
due to improper validation of the length of encoded
data. An unauthenticated, remote attacker can exploit
this to cause a denial of service condition or the
execution of arbitrary code. (VulnDB 145607)

- A NULL pointer dereference flaw exists in the
CachingIterator() function within file
ext/spl/spl_iterators.c when handling string
conversions. An unauthenticated, remote attacker can
exploit this to cause a denial of service condition.
(VulnDB 145608)

- An integer overflow condition exists in the
number_format() function within file ext/standard/math.c
when handling 'decimals' and 'dec_point' parameters that
have values that are equal or close to 0x7fffffff. An
unauthenticated, remote attacker can exploit this to
cause a heap buffer overflow, resulting in a denial of
service condition or the execution of arbitrary code.
(VulnDB 145609)

- A stack-based overflow condition exists in the
ResourceBundle::create and ResourceBundle::getLocales
methods and their respective functions within file
ext/intl/resourcebundle/resourcebundle_class.c due to
improper validation of input passed via the 'bundlename'
parameter. An unauthenticated, remote attacker can
exploit this to cause a denial of service condition or
the execution or arbitrary code. (VulnDB 145610)

- An integer overflow condition exists in the
php_pcre_replace_impl() function within file
ext/pcre/php_pcre.c due to improper validation of
user-supplied input. An unauthenticated, remote attacker
can exploit this to cause a heap-based buffer overflow,
resulting in a denial of service condition or the
execution of arbitrary code. (VulnDB 145611)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://php.net/ChangeLog-5.php#5.6.27

Solution :

Upgrade to SecurityCenter version 5.4.1 or later. Alternatively,
contact the vendor for a patch.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 101049 ()

Bugtraq ID: 93577

CVE ID: CVE-2016-9137

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now