Tenable SecurityCenter Apache 2.4.x < 2.4.25 Multiple Vulnerabilities (TNS-2017-04) (httpoxy)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The Tenable SecurityCenter application on the remote host contains a
web server that is affected by multiple vulnerabilities.

Description :

The Tenable SecurityCenter application installed on the remote host
is missing a security patch. It is, therefore, affected by multiple
vulnerabilities in the bundled version of Apache :

- A flaw exists in the mod_session_crypto module due to
encryption for data and cookies using the configured
ciphers with possibly either CBC or ECB modes of
operation (AES256-CBC by default). An unauthenticated,
remote attacker can exploit this, via a padding oracle
attack, to decrypt information without knowledge of the
encryption key, resulting in the disclosure of
potentially sensitive information. (CVE-2016-0736)

- A denial of service vulnerability exists in the
mod_auth_digest module during client entry allocation.
An unauthenticated, remote attacker can exploit this,
via specially crafted input, to exhaust shared memory
resources, resulting in a server crash. (CVE-2016-2161)

- The Apache HTTP Server is affected by a
man-in-the-middle vulnerability known as 'httpoxy' due
to a failure to properly resolve namespace conflicts in
accordance with RFC 3875 section 4.1.18. The HTTP_PROXY
environment variable is set based on untrusted user data
in the 'Proxy' header of HTTP requests. The HTTP_PROXY
environment variable is used by some web client
libraries to specify a remote proxy server. An
unauthenticated, remote attacker can exploit this, via a
crafted 'Proxy' header in an HTTP request, to redirect
an application's internal HTTP traffic to an arbitrary
proxy server where it may be observed or manipulated.
(CVE-2016-5387)

- A denial of service vulnerability exists in the
mod_http2 module due to improper handling of the
LimitRequestFields directive. An unauthenticated, remote
attacker can exploit this, via specially crafted
CONTINUATION frames in an HTTP/2 request, to inject
unlimited request headers into the server, resulting in
the exhaustion of memory resources. (CVE-2016-8740)

- A flaw exists due to improper handling of whitespace
patterns in user-agent headers. An unauthenticated,
remote attacker can exploit this, via a specially
crafted user-agent header, to cause the program to
incorrectly process sequences of requests, resulting in
interpreting responses incorrectly, polluting the cache,
or disclosing the content from one request to a second
downstream user-agent. (CVE-2016-8743)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.tenable.com/security/tns-2017-04
https://static.tenable.com/prod_docs/upgrade_security_center.html
http://httpd.apache.org/security/vulnerabilities_24.html

Solution :

Upgrade to Tenable SecurityCenter version 5.4.3 or later.
Alternatively, contact the vendor for a patch.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.4
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 101044 ()

Bugtraq ID: 91816
94650
95076
95077
95078

CVE ID: CVE-2016-0736
CVE-2016-2161
CVE-2016-5387
CVE-2016-8740
CVE-2016-8743

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now