Chainguard: geoserver-2.28-community: security update to 2.28.6-r3

high Tenable Self-Hosted Container Security Plugin ID 478592

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache
ActiveMQ All. Following the fix for CVE-2026-49270 an unauthenticated attacker can now cause broker OOM by
sending an repeated BrokerInfo commands without sending a ConnectionInfo, until the broker will crash with
OOM. This issue affects Apache ActiveMQ Broker: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache
ActiveMQ: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ All: from 5.19.7 before
5.19.8, from 6.2.6 before 6.2.7. Users are recommended to upgrade to version 6.2.7, which fixes the issue.
(CVE-2026-50750)

Solution

Update the geoserver-2.28-community library and its related packages to version 2.28.6-r3 or later.

Plugin Details

Severity: High

ID: 478592

Version: Revision 1.1

Type: Local

Published: 11/6/2026

Updated: 11/6/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.71

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-50750

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 6/30/2026

Reference Information

CVE: CVE-2026-50750