Echo: openssl-1.0.1g: security update to 1.0.1g+e1

medium Tenable Self-Hosted Container Security Plugin ID 478522

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The BN_GF2m_mod_inv function in crypto/bn/bn_gf2m.c in OpenSSL before 0.9.8s, 1.0.0 before 1.0.0e, 1.0.1
before 1.0.1n, and 1.0.2 before 1.0.2b does not properly handle ECParameters structures in which the curve
is over a malformed binary polynomial field, which allows remote attackers to cause a denial of service
(infinite loop) via a session that uses an Elliptic Curve algorithm, as demonstrated by an attack against
a server that supports client authentication. (CVE-2015-1788)

Solution

Update the openssl-1.0.1g library and its related packages to version 1.0.1g+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2015-1788

Plugin Details

Severity: Medium

ID: 478522

Version: Revision 1.1

Type: Local

Published: 11/5/2026

Updated: 11/5/2026

Risk Information

VPR

Risk Factor: Low

Score: 2.1

Percentile: 6.91

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2015-1788

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/5/2026

Vulnerability Publication Date: 9/6/2011

Reference Information

CVE: CVE-2015-1788