SCA: security update for org.apache.activemq:apache-activemq (GHSA-f892-4h9f-j7g9)

high Tenable Self-Hosted Container Security Plugin ID 478350

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user
by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not
limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before
6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
(CVE-2026-49877)

Solution

Update the org.apache.activemq:apache-activemq library and its related packages to version 5.19.8 or later.

See Also

https://github.com/advisories/GHSA-f892-4h9f-j7g9

Plugin Details

Severity: High

ID: 478350

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 11/4/2026

Updated: 11/4/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.64

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:N

CVSS Score Source: CVE-2026-49877

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 6/30/2026

Vulnerability Publication Date: 6/30/2026

Reference Information

CVE: CVE-2026-49877

cwe: CWE-285