Echo: sqlite3: security update to 3.46.1-7+e9

medium Tenable Self-Hosted Container Security Plugin ID 478165

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows attackers to bypass the
SQLITE_LIMIT_EXPR_DEPTH limit by chaining COLLATE postfix operators. Attackers can supply roughly 175,000
chained COLLATE operators in SQL or an untrusted database view to trigger unbounded recursion in
sqlite3WalkExprNN() and crash the process. (CVE-2026-119376)

Solution

Update the sqlite3 library and its related packages to version 3.46.1-7+e9 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-119376

Plugin Details

Severity: Medium

ID: 478165

Version: Revision 1.1

Type: Local

Published: 11/2/2026

Updated: 11/2/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.72

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-119376

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: Medium

Base Score: 6.8

Threat Score: 4.3

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/1/2026

Vulnerability Publication Date: 10/30/2026

Reference Information

CVE: CVE-2026-119376