Description
There are packages installed that are affected by a vulnerability referenced in the following CVE:
- vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes
attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder
selection, and the MIME label does not constrain the selected format. Image-capable request paths through
parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with
Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while
environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading
workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding
impact. This issue is fixed in version 0.32.0. (CVE-2026-115915)
Solution
Update the vllm-omni-cuda-13.0 library and its related packages to version 0.32.0-r0 or later.
Plugin Details
Risk Information
Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C
Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C
Vulnerability Information
Exploit Ease: No known exploits are available
Vulnerability Publication Date: 10/26/2026