Echo: firebird4.0: security update to 4.0.5.3140.ds6-17+deb13u1+e1

high Tenable Self-Hosted Container Security Plugin ID 477742

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and
3.0.14, when deserializing a slice packet, the xdr_datum() function does not validate that a cstring
length conforms to the slice descriptor bounds, allowing a cstring longer than the allocated buffer to
overflow it. An unauthenticated attacker can exploit this by sending a crafted packet to the server,
potentially causing a crash or other security impact. This issue has been fixed in versions 5.0.4, 4.0.7
and 3.0.14. (CVE-2026-33337)

Solution

Update the firebird4.0 library and its related packages to version 4.0.5.3140.ds6-17+deb13u1+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-33337

Plugin Details

Severity: High

ID: 477742

Version: Revision 1.1

Type: Local

Published: 10/29/2026

Updated: 10/29/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.63

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-33337

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/28/2026

Vulnerability Publication Date: 4/17/2026

Reference Information

CVE: CVE-2026-33337