Chainguard: ecpg-17, multiple libecpg-17 packages, multiple postgresql-17 packages: security update to 17.11-r0

medium Tenable Self-Hosted Container Security Plugin ID 477714

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Missing authorization in PostgreSQL DDL commands allows an object creator to achieve denial of service
against ALTER and DROP of the type, via creating a dependency on the type. Many DDL operations did check
the privilege, but assigning a range subtype and referencing the type from an SQL expression did not.
Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected. (CVE-2026-6470)

Solution

Update the ecpg-17 library and its related packages to version 17.11-r0 or later.

Plugin Details

Severity: Medium

ID: 477714

Version: Revision 1.1

Type: Local

Published: 10/28/2026

Updated: 10/28/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

CVSS Score Source: CVE-2026-6470

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 8/13/2026

Reference Information

CVE: CVE-2026-6470