SCA: security update for @ckeditor/ckeditor5-engine, ckeditor5 (GHSA-v6mg-96c6-gmpq)

low Tenable Self-Hosted Container Security Plugin ID 477699

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and
48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and
specifically configured to allow object content. Processing that content can execute attacker-controlled
JavaScript in a browser context isolated from the origin of the application embedding the editor. This
issue is fixed in versions 47.7.4 and 48.5.1. (CVE-2026-116687)

Solution

Update the @ckeditor/ckeditor5-engine library and its related packages to version 47.7.4 or later.

See Also

https://github.com/advisories/GHSA-v6mg-96c6-gmpq

Plugin Details

Severity: Low

ID: 477699

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 10/28/2026

Updated: 10/28/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

Vendor

Vendor Severity: Low

CVSS v2

Risk Factor: Low

Base Score: 2.1

Temporal Score: 1.6

Vector: CVSS2#AV:N/AC:H/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2026-116687

CVSS v3

Risk Factor: Low

Base Score: 3.1

Temporal Score: 2.7

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/27/2026

Vulnerability Publication Date: 10/27/2026

Reference Information

CVE: CVE-2026-116687

cwe: CWE-79