SCA: security update for org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat-coyote (GHSA-f525-44xv-f2qj)

critical Tenable Self-Hosted Container Security Plugin ID 477665

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This
issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115
through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the
issue. (CVE-2026-65637)

Solution

Update the org.apache.tomcat.embed:tomcat-embed-core library and its related packages to version 10.1.59 or later.

See Also

https://github.com/advisories/GHSA-f525-44xv-f2qj

Plugin Details

Severity: Critical

ID: 477665

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 10/27/2026

Updated: 10/27/2026

Risk Information

VPR

Risk Factor: Medium

Score: 6.9

Percentile: 96.41

Vendor

Vendor Severity: Critical

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-65637

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 8/26/2026

Vulnerability Publication Date: 8/18/2026

Reference Information

CVE: CVE-2026-65637

cwe: CWE-20