Echo: imagemagick: security update to 8:7.1.2.33+dfsg1-1

low Tenable Self-Hosted Container Security Plugin ID 477537

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- ImageMagick before 7.1.2-33 contains a heap buffer overflow vulnerability on 32-bit systems that allows
attackers to overwrite heap memory when convex-hull information is requested. Attackers can supply crafted
images processed with convex-hull calculations to corrupt heap memory, causing crashes or potential code
execution. (CVE-2026-116153)

Solution

Update the imagemagick library and its related packages to version 8:7.1.2.33+dfsg1-1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-116153

Plugin Details

Severity: Low

ID: 477537

Version: Revision 1.1

Type: Local

Published: 10/27/2026

Updated: 10/27/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Low

Base Score: 1.2

Temporal Score: 0.9

Vector: CVSS2#AV:L/AC:H/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2026-116153

CVSS v3

Risk Factor: Low

Base Score: 2.5

Temporal Score: 2.2

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: Low

Base Score: 2

Threat Score: 0.4

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/26/2026

Vulnerability Publication Date: 10/25/2026

Reference Information

CVE: CVE-2026-116153