Echo: php-7.2: security update to 7.2.34+e1

high Tenable Self-Hosted Container Security Plugin ID 477453

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 7.3.x up to and including 7.3.31, 7.4.x below 7.4.25 and 8.0.x below 8.0.12, when running
PHP FPM SAPI with main FPM daemon process running as root and child worker processes running as lower-
privileged users, it is possible for the child processes to access memory shared with the main process and
write to it, modifying it in a way that would cause the root process to conduct invalid memory reads and
writes, which can be used to escalate privileges from local unprivileged user to the root user.
(CVE-2021-21703)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2021-21703

Plugin Details

Severity: High

ID: 477453

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Medium

Score: 6.9

Percentile: 97.16

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2021-21703

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.3

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 10/18/2021

Reference Information

CVE: CVE-2021-21703