Echo: php-7.2: security update to 7.2.34+e1

critical Tenable Self-Hosted Container Security Plugin ID 477443

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, uncontrolled long string
inputs to ldap_escape() function on 32-bit systems can cause an integer overflow, resulting in an out-of-
bounds write. (CVE-2024-8932)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2024-8932

Plugin Details

Severity: Critical

ID: 477443

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 57.77

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2024-8932

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 11/19/2024

Reference Information

CVE: CVE-2024-8932