Echo: php-7.2: security update to 7.2.34+e1

medium Tenable Self-Hosted Container Security Plugin ID 477437

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3, password_verify() function may
accept some invalid Blowfish hashes as valid. If such invalid hash ever ends up in the password database,
it may lead to an application allowing any password for this entry as valid. (CVE-2023-0567)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2023-0567

Plugin Details

Severity: Medium

ID: 477437

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.67

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.8

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2023-0567

CVSS v3

Risk Factor: Medium

Base Score: 6.2

Temporal Score: 5.6

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 2/15/2023

Reference Information

CVE: CVE-2023-0567